Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

MoonlightScrappin Offline
#1 Posted : Wednesday, December 22, 2010 6:11:23 PM(UTC)
MoonlightScrappin

Rank: Newbie

Groups: Registered
Joined: 5/11/2010(UTC)
Posts: 5

Hi all, I'm new to provo community. I just got my Gypsy and fumbled my way through registering it and syncing it. But I can't seem to get it charged. It seems pretty simple just attached the charging cord and plug to the wall. But it's been charging since last night and when I unplug it and try turning it on, it won't come on. If it's pluged I can turn it on without a problem. Could it be defective? Or am I doing something wrong? Any suggestions would be wonderful. By the time I finished up with work today, it was too late to call provo craft so I thought I'd stop by and see if someone could assist me here.

Also, while I'm here...I did the registration and the synching, even added my cartidges. But it's never prompted me to get the 5 free cartridges. Upon reviewing the cartridge list...and chosing the ones linked to this Gypsy option, I found that instead of getting the 5 featured free cartridges I only got one off of the list, "Tags, Bags, Boxes and more", and only 3 other ramdom ones, "Paper Pups, Christmas Cheer, and All Mixed up". I didn't get a fifth one nor are they the ones that were advertised... any clue as to why? Has anyone else had this happen?

Thanks in advance for taking the time to help me out!
Doxieluv01 Offline
#2 Posted : Wednesday, December 22, 2010 7:17:36 PM(UTC)
Doxieluv01

Rank: Advanced Member

Groups: Registered
Joined: 1/18/2007(UTC)
Posts: 9,716
Location: Sunny S. Florida

Thanks: 926 times
Was thanked: 2263 time(s) in 1789 post(s)
are you holding the power button down for about 2-3 seconds when turning it on?

have you tried a different power outlet?

are you sure the power cord is all the way in the G?

as far as the free carts where did you get your G from?

what is the version number of your G click the wrench on the welcome screen and tell us the numbers in ( )
MoonlightScrappin Offline
#3 Posted : Wednesday, December 22, 2010 7:28:15 PM(UTC)
MoonlightScrappin

Rank: Newbie

Groups: Registered
Joined: 5/11/2010(UTC)
Posts: 5

are you holding the power button down for about 2-3 seconds when turning it on?
Yes, I have tried holding it down longer when it's not pluged in. It comes one after a few seconds when it's pluged in.

have you tried a different power outlet?
Yes, that has not made a difference, when I first got it out of the box, I turned it on and it died within seconds...so I plugged it in to charge and I've not been able to get it to come on since then without it being plugged in

are you sure the power cord is all the way in the G?
I have it as deep as it will go, but it isn't all the way in the silver prong sticks out a little, do you think that's the problem?

as far as the free carts where did you get your G from?
purchased it from Provo Craft

what is the version number of your G click the wrench on the welcome screen and tell us the numbers in ( )(0206-0209)

Thanks for helping me.BigGrin
Doxieluv01 Offline
#4 Posted : Wednesday, December 22, 2010 7:35:39 PM(UTC)
Doxieluv01

Rank: Advanced Member

Groups: Registered
Joined: 1/18/2007(UTC)
Posts: 9,716
Location: Sunny S. Florida

Thanks: 926 times
Was thanked: 2263 time(s) in 1789 post(s)
have you let it charge for at least 4 hours before trying to turn it on and use it?
MoonlightScrappin Offline
#5 Posted : Wednesday, December 22, 2010 7:58:04 PM(UTC)
MoonlightScrappin

Rank: Newbie

Groups: Registered
Joined: 5/11/2010(UTC)
Posts: 5

Yes, after I registered and synced it last night I lefted it charging for 8 hours. And it's been charging most of the day today.

It's wiered, I cant figure it out.

So, do you think the version I have will not accept the 5 free cartridges?

Guess I'll just have to wait and see if I can call Provo tomorrow before they close and see what they have to say about all this.
Doxieluv01 Offline
#6 Posted : Wednesday, December 22, 2010 8:04:17 PM(UTC)
Doxieluv01

Rank: Advanced Member

Groups: Registered
Joined: 1/18/2007(UTC)
Posts: 9,716
Location: Sunny S. Florida

Thanks: 926 times
Was thanked: 2263 time(s) in 1789 post(s)
MoonlightScrappin wrote:
Yes, after I registered and synced it last night I lefted it charging for 8 hours. And it's been charging most of the day today.

It's wiered, I cant figure it out.

So, do you think the version I have will not accept the 5 free cartridges?

Guess I'll just have to wait and see if I can call Provo tomorrow before they close and see what they have to say about all this.


no you have the correct version of your G. not sure what the problem is. I would definately call PC.
MoonlightScrappin Offline
#7 Posted : Wednesday, December 22, 2010 9:24:25 PM(UTC)
MoonlightScrappin

Rank: Newbie

Groups: Registered
Joined: 5/11/2010(UTC)
Posts: 5

Will do, thanks again for trying to help!
DoodleBug2 Offline
#8 Posted : Thursday, December 23, 2010 7:47:31 AM(UTC)
DoodleBug2

Rank: Advanced Member

Groups: Registered
Joined: 1/14/2009(UTC)
Posts: 597
Location: Idaho

Thanks: 294 times
Was thanked: 119 time(s) in 113 post(s)
Sometimes you can overcharge your G, and I think that might be what has happened - If you can get your G to turn on, I would let the battery run down for a bit - I only leave my G charging for two hours.
SBJillsy Offline
#9 Posted : Thursday, December 23, 2010 8:07:32 AM(UTC)
SBJillsy

Rank: Newbie

Groups: Registered
Joined: 3/21/2008(UTC)
Posts: 3

I have a brand new G and am puzzled just by trying to charge it. I have the same issue mentioned earlier about the silver prong sticking out a little when it's fully pushed into the G. Is that normal? When I charge my cellphone or some other device, the silver prong goes all the way in and only the black plastic part is visible...not sure why the G charger is different.

Also, is there any indication that it is charging? Should the light come on or is there an icon to indicate it is charging? When I plug mine in and it is turned off, nothing happens. I tried looking in the manual and didn't find anything. I checked the battery level by pushing the silver button. When mine is plugged in, it displays a plug icon over the battery icon, so I assume that means it's charging. When I unplug it, the plug icon goes away and you just see the battery icon.

And that brings me to my last question (for this post!)...what does the battery icon look like when it's fully charged? Is it all pinkish purple? Or does that mean it's completely drained? Mine has looked the same the entire time...before and after attempting to charge.

Any help or advice is appreciated!!
DoodleBug2 Offline
#10 Posted : Thursday, December 23, 2010 8:21:13 AM(UTC)
DoodleBug2

Rank: Advanced Member

Groups: Registered
Joined: 1/14/2009(UTC)
Posts: 597
Location: Idaho

Thanks: 294 times
Was thanked: 119 time(s) in 113 post(s)
SBJillsy wrote:
I have a brand new G and am puzzled just by trying to charge it. I have the same issue mentioned earlier about the silver prong sticking out a little when it's fully pushed into the G. Is that normal? When I charge my cellphone or some other device, the silver prong goes all the way in and only the black plastic part is visible...not sure why the G charger is different.

Also, is there any indication that it is charging? Should the light come on or is there an icon to indicate it is charging? When I plug mine in and it is turned off, nothing happens. I tried looking in the manual and didn't find anything. I checked the battery level by pushing the silver button. When mine is plugged in, it displays a plug icon over the battery icon, so I assume that means it's charging. When I unplug it, the plug icon goes away and you just see the battery icon.

And that brings me to my last question (for this post!)...what does the battery icon look like when it's fully charged? Is it all pinkish purple? Or does that mean it's completely drained? Mine has looked the same the entire time...before and after attempting to charge.

Any help or advice is appreciated!!


The prong on the charging cord does not go clear in - if you force it, it will break the G. It has always been this way since the G first came out.

When you have the G plugged in to an electrical outlet for charging the battery icon will have a plug on top of it. To check if your battery is charged or how much it is charged, unplug the G and if the battery icon is all pinkish red it is fully charged - if it is pink and white it is only partially charged.

When the battery is getting low, and red light will flash at the on/off button, which is normally blue when the G is on and charged. Hope this helps
SBJillsy Offline
#11 Posted : Thursday, December 23, 2010 9:25:50 AM(UTC)
SBJillsy

Rank: Newbie

Groups: Registered
Joined: 3/21/2008(UTC)
Posts: 3

Thanks DoodleBug! Not sure the G is going to be the best tool for me if I can't even figure out how to charge the silly thingLaugh .
MoonlightScrappin Offline
#12 Posted : Thursday, December 23, 2010 10:34:47 AM(UTC)
MoonlightScrappin

Rank: Newbie

Groups: Registered
Joined: 5/11/2010(UTC)
Posts: 5

DoodleBug2 wrote:
Sometimes you can overcharge your G, and I think that might be what has happened - If you can get your G to turn on, I would let the battery run down for a bit - I only leave my G charging for two hours.


That's the problem, it has NEVER been on since I got it without it being plug in. It does not respond at all no red, blue or any light when I try to turn it on if it's not plugged in.
SBJillsy Offline
#13 Posted : Thursday, December 23, 2010 6:41:05 PM(UTC)
SBJillsy

Rank: Newbie

Groups: Registered
Joined: 3/21/2008(UTC)
Posts: 3

Even though I should be wrapping presents, I was successful in registering the G and getting everything loaded, including the 5 free carts. Took a few tries. Hang in there Moonlight Scrappin and good luck!
Doxieluv01 Offline
#14 Posted : Thursday, December 23, 2010 6:45:08 PM(UTC)
Doxieluv01

Rank: Advanced Member

Groups: Registered
Joined: 1/18/2007(UTC)
Posts: 9,716
Location: Sunny S. Florida

Thanks: 926 times
Was thanked: 2263 time(s) in 1789 post(s)
SBJillsy wrote:
Even though I should be wrapping presents, I was successful in registering the G and getting everything loaded, including the 5 free carts. Took a few tries. Hang in there Moonlight Scrappin and good luck!


yay!!! glad you were able to get your G updated. have fun playing with her!!
☼scrappingjoy☼ Offline
#15 Posted : Sunday, December 26, 2010 4:24:22 PM(UTC)
☼scrappingjoy☼

Rank: Advanced Member

Groups: Registered
Joined: 7/21/2008(UTC)
Posts: 308
Location: Pennsylvainia

Thanks: 71 times
Was thanked: 73 time(s) in 50 post(s)
I have a silly question about charging. when you charge it do you have to have the gyspy turned on or just plug it in???
Doxieluv01 Offline
#16 Posted : Sunday, December 26, 2010 4:40:12 PM(UTC)
Doxieluv01

Rank: Advanced Member

Groups: Registered
Joined: 1/18/2007(UTC)
Posts: 9,716
Location: Sunny S. Florida

Thanks: 926 times
Was thanked: 2263 time(s) in 1789 post(s)
☼scrappingjoy☼ wrote:
I have a silly question about charging. when you charge it do you have to have the gyspy turned on or just plug it in???


just plug it in
☼scrappingjoy☼ Offline
#17 Posted : Sunday, December 26, 2010 4:52:27 PM(UTC)
☼scrappingjoy☼

Rank: Advanced Member

Groups: Registered
Joined: 7/21/2008(UTC)
Posts: 308
Location: Pennsylvainia

Thanks: 71 times
Was thanked: 73 time(s) in 50 post(s)
thanks another question... how do you know when the battery is fully charged??

Edited by user Sunday, December 26, 2010 4:53:07 PM(UTC)  | Reason: added another question

Doxieluv01 Offline
#18 Posted : Sunday, December 26, 2010 4:56:55 PM(UTC)
Doxieluv01

Rank: Advanced Member

Groups: Registered
Joined: 1/18/2007(UTC)
Posts: 9,716
Location: Sunny S. Florida

Thanks: 926 times
Was thanked: 2263 time(s) in 1789 post(s)
☼scrappingjoy☼ wrote:
thanks another question... how do you know when the battery is fully charged??


when you turn your gypsy on if you click the small round silver button it will show you the battery indicator
☼scrappingjoy☼ Offline
#19 Posted : Sunday, December 26, 2010 5:13:07 PM(UTC)
☼scrappingjoy☼

Rank: Advanced Member

Groups: Registered
Joined: 7/21/2008(UTC)
Posts: 308
Location: Pennsylvainia

Thanks: 71 times
Was thanked: 73 time(s) in 50 post(s)
thanks so much... as you can tell I'm a new owner.
AJoy713 Offline
#20 Posted : Tuesday, December 28, 2010 6:02:52 PM(UTC)
AJoy713

Rank: Newbie

Groups: Registered
Joined: 12/22/2008(UTC)
Posts: 2

MoonlightScrappin wrote:
That's the problem, it has NEVER been on since I got it without it being plug in. It does not respond at all no red, blue or any light when I try to turn it on if it's not plugged in.

I am having the same issue with my Gypsy. When I contacted ProvoCraft the sales rep asked a few questions, mentioned that the first time you charge it you are supposed to charge it for 24 hours without using it, had me try to update the software and while I was doing that she came back really quickly and said they would replace it. I was pretty surprised that she said they would replace it after talking to me for about 3 min. It made me think that there was many people having this issue.

I didn't get into the details about the replacement because I have to get the receipt from my mother-in-law. Be sure to have that before you spend 40 min on hold Laugh .

Hope that helps.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 1.051 seconds.
nebo-cricut-01