• Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.



jojo94971d3da773 Offline
#1 Posted : Sunday, April 08, 2012 4:05:32 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 4/8/2012(UTC)
Posts: 1

Please help! I was using Cricut Craft room with a cartridge I own. When I went connected PC to Cricut, it asked me to download some software. Which I did and all seemed great. When I tried to cut my design, I started getting errors. It did not recognize my machine, then said I needed to download the software, on and on with problems. I got very frustrated and gave up and just piped out my design by hand. This is not what I bought the Cricut for!! Now, even when trying to use Cricut when it is not attached to my PC, it does not recognize that a cartridge is in. I start it up without a cartridge and it says insert cartridge. I do. It does nothing. Cannot load a mat, no buttons light up. I am very frustrated. I have a big wedding cake coming up that I planned on using some cricut designs and bought cartridges just for it.

I have tried resetting the Cricut several times with no luck. Can anyone help me?

This cost a lot of money, plus the 5 cartridges are not cheap....and I cannot use it!!Mad

Johanna Altman
ladykinstered5be36b Offline
#2 Posted : Tuesday, July 02, 2013 10:43:51 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 7/2/2013(UTC)
Posts: 1

I know you posted this a year ago, but my cricut cake is doing the exact same thing. Did you ever get it resolved?

***I have the Martha Stewart edition, expression size. Mine went loopy before using any design software.***

Edited by user Tuesday, July 02, 2013 10:45:55 PM(UTC)  | Reason: Not specified

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2015, Yet Another Forum.NET
This page was generated in 3.964 seconds.