• Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.



annbog43191a72 Offline
#1 Posted : Sunday, August 19, 2012 3:24:41 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 8/8/2012(UTC)
Posts: 1

I have been trying to update the firmware so that I can cut from a digital cartridge. It says that it is updating. It has now been updating for about 1 1/2 hours. How long should this take? I afraid to start over because it says on the computer screen that it could cause my cricut to no longer function properly. Any insight?
tdurningfbac31d3 Offline
#2 Posted : Sunday, August 19, 2012 3:34:05 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 8/19/2012(UTC)
Posts: 3

Hi, I am doing the exact same thing and hopefully I did not ruin my cricut, maybe there is a problem with the program right now. Someone else said it only took minutes!
michaelf989ab8b Offline
#3 Posted : Saturday, September 01, 2012 7:36:30 AM(UTC)

Rank: Newbie

Groups: Registered
Joined: 9/1/2012(UTC)
Posts: 1

For what it's worth, I tried and tried, but never got anywhere trying to do this on my Mac (10.7). On a hunch, I fired up Windows XP (via Parallels), installed Craft Room, and it worked on the first try. It actually strikes me as quite odd since they use Adobe AIR for Craft Room, which should by and large make the operating system a moot point.
Angie R Offline
#4 Posted : Sunday, September 02, 2012 3:14:02 PM(UTC)
Angie R

Rank: Newbie

Groups: Registered
Joined: 3/19/2010(UTC)
Posts: 6
Location: BC

Thanks: 2 times
Was thanked: 2 time(s) in 1 post(s)
OP what eventually happened? I'm updating mine right now and it has been just sitting here doing nothing for about 20 minutes so far?
MeganC Offline
#5 Posted : Thursday, September 06, 2012 7:10:03 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 12/17/2007(UTC)
Posts: 2
Location: Austin, Texas

I'm having the same issue. It gets 2/3rds of the way through the update and then freezes.....all of this after pulling my E1 out because my E2 is not working with craft room. I know have two cricut machines and none working with CR...so much for thinking I could use the digital cartridges.... UGHHHHH getting really frustrated. I have birthday invitations I need to cut.
Shelly Offline
#6 Posted : Wednesday, September 26, 2012 3:46:04 PM(UTC)

Rank: Advanced Member

Groups: Registered
Joined: 11/8/2010(UTC)
Posts: 950
United States
Location: Sandy, UT

Thanks: 283 times
Was thanked: 334 time(s) in 292 post(s)
I just had to replace my gypsy. Went to do my first cut with it and it says I need to update my expression. Didn't have to with my old gypsy. Has there been an update recently that made everyone have to update their expression?
allisonmbergercd442810 Offline
#7 Posted : Wednesday, September 26, 2012 6:16:04 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 9/25/2012(UTC)
Posts: 2

I just got my expression and I am trying SO hard to update to use it with craft room. I only have a mac, and I was told it would work with it. Has anyone heard anything about how to get the firmware updated?
gjcloke70de8a43 Offline
#8 Posted : Thursday, September 27, 2012 8:29:31 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 9/1/2012(UTC)
Posts: 1

I bought an Expression from a friend of my daughter's. She hadn't used it much and looked like new. It worked great at first for about 2 hours. Then it locked up with a bunch of lights on and I haven't been able to use it since. It has been over a month now. The support people at Cricut had me download a program to take it out of "firmware mode," which I never had it in to begin with, but maybe the previous owner did. I tried this over and over and over. It didn't do a thing. I've tried leaving it off and randomly turning it on. Sometimes it comes on and looks OK, but when I try to do anything other than the power button, the lights come on and it is still locked up. Any suggestions???? My daughter's Essential did this right after she got hers when it was brand new, so I'm not convince there is something wrong with my machine. I think it may be a software glitch. Crying

I appreciate any suggestions.

Jean C.
cherylboeschen9a8a1c57 Offline
#9 Posted : Wednesday, October 03, 2012 8:22:06 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 10/3/2012(UTC)
Posts: 1

I just bought a digital cartridge, for Halloween. It was a 60 day rental. Well I have never used Cricut Craft room before but figured it couldn't be hard. Well it has done nothing but memss up my Cricut Expression, and my computer. I bought it Sunday and it is now Wed, and I still have not used it yet. After working with both Cricut, and my Bidefender techs to get it loaded, I was able to install it, then I went to update the firmware, and it stopped in the middle, I was afraid to shut it down, so it ran all night - stuck. I turned it off, re-ran the firmware, and it does the same thing. I am so frustrated right now. I hope this stupid digital cartridge has not ruin my Cricut Expression. I will be so mad, I have had it for 2 years and love and use it all the time with my granddaughters. I am not giving up, one way or another I am getting this to work, or someone is going to be buying me another machine! Somebody please give me some helpful news. I wish I had read all these posts before purchasing. I don't think I would have bought it! Help!
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2015, Yet Another Forum.NET
This page was generated in 3.117 seconds.