Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

JanaBailey Offline
#1 Posted : Saturday, October 27, 2012 1:37:21 PM(UTC)
JanaBailey

Rank: Advanced Member

Groups: Registered
Joined: 5/11/2006(UTC)
Posts: 472
Location: Texas

Thanks: 58 times
Was thanked: 169 time(s) in 110 post(s)
I have feared this would some day happen to me too. I have had my Imagine since launch and NEVER had any problems until the update before last and now my machine will not cut! I also updated the CCR and it worked with it for only 1 day then nothing. Just printing and no cutting! I have done the restore 3 times and it has not helped at all! It won't cut connected to CCR or stand alone. I called CS and the girl told me to revert back to an older version of CCR and that should fix it. She sent me a link and surprise, surprise, the link doesn't even work. How is reverting to an old version of CCR supposed to make my machine run stand alone? I have been trying for 3 days straight to make it work and it only prints then ejects the mat. Sometimes it will then cut into the bed of the machine as if the mat were there but it's not.

I am just sick to my stomach about this. This is the tool I use ALL THE TIME!! I am so sad. I thought I would replace it with another Cricut but after reading other threads, it seems the problems are in every machine.

I have been loyal to PC through all the garbage over the years,through boycotts, bad updates, lawsuits, etc. I have stuck by them and even recommended machines to many of my friends. Now I am embarrassed that many of my friends have bought Imagines because of my raving over how wonderful it is. I feel foolish!

I guess it is time to look at other machines. What to do with my over 200 cartridges???Crying
Blessings all,
Jana
sewnmachine Offline
#2 Posted : Saturday, October 27, 2012 2:50:52 PM(UTC)
sewnmachine

Rank: Advanced Member

Groups: Registered
Joined: 2/4/2012(UTC)
Posts: 639

Thanks: 55 times
Was thanked: 348 time(s) in 232 post(s)
Jana,

I know this is no consolation, but since you have 200 carts you have a really big investment made. Why don't you consider getting a new E2 that will work with all your carts. Don't do any freakin updates, and just go back to having fun crafting the "stand alone way". No CCR, no Gypsy linking, no printing..... just cutting. There will probably be lots of good deals to be found, and the E2 probably has enough bells and whistles to get the job done for you.

Don't be tempted to hook your machine up to CCR or your computer - no matter what. Just browse through your handbooks (if you have a tablet, why not download all the handbooks onto it) and then you can browse through them, and plan designs and layouts - but without the fear of updates killing your machine.

You could still buy new carts if something catches your eye, and just know it will work without all the hocus pocus of updating or using CCR.

Just maybe something to think about.
keysdeb Offline
#3 Posted : Saturday, October 27, 2012 3:11:39 PM(UTC)
keysdeb

Rank: Advanced Member

Groups: Registered
Joined: 7/31/2011(UTC)
Posts: 127
Location: Fabulous Florida Keys!!

Thanks: 21 times
Was thanked: 30 time(s) in 24 post(s)
There is nothing more frustrating than technology when it doesn't work!! I have to say I love my original Personal Cricut. I purchased for $70.00 on Black Friday at Joannes.com two years ago. I love it. Everytime I am tempted to upgrade I read the past posts and give my oldie but goodie a little pat. I never have a problem with it. BigGrin
JanaBailey Offline
#4 Posted : Sunday, October 28, 2012 1:21:51 PM(UTC)
JanaBailey

Rank: Advanced Member

Groups: Registered
Joined: 5/11/2006(UTC)
Posts: 472
Location: Texas

Thanks: 58 times
Was thanked: 169 time(s) in 110 post(s)
You know, "sewnmachine" I like your positive attitude and I think that is what I am going to do. I have wanted an E2 and this just might be the right excise to get one. I can still use my Imagine to print papers, I think... I will try it out maybe after Christmas I can find a good deal on the E2.
Thanks!
Jana
JanaBailey Offline
#5 Posted : Saturday, November 03, 2012 6:29:27 PM(UTC)
JanaBailey

Rank: Advanced Member

Groups: Registered
Joined: 5/11/2006(UTC)
Posts: 472
Location: Texas

Thanks: 58 times
Was thanked: 169 time(s) in 110 post(s)
Update~The customer service person that emailed me the bad link stopped replying to my emails. Left me high and dry with no link at all. I was so disappointed, I usually get really go cs when I call. So I felt that I had to tackle the whole thing again.

So....
after hours and hours, even days of experimenting and trying to get my I to cut again, it is finally working. I ran the restore two more times until it made it through the process without getting stuck. It still wasn't cutting so I tried cutting again with CCR and it didn't work but then I thought I would try using my Gypsy and it actually CUT!

I thought it was strange and realized that if it could cut with the gypsy it HAD to be able to cut alone, so I again called PC and talked with a new person that kept urging me to buy new mats even after I told her that I had good, clean mats and then she suggested that I take my machine and use another computer to run the restore on it. I didn't want to do that so I thought I would "appease" her by going and buying new mats just to be able to say I tried it and it didn't work. But guess what???? So far, it is cutting in CCR, alone and with my Gypsy. She said that she thought the machine was having a hard time recognizing the mat so I needed to try a new one. Thanks you Kaila Christenson!!!! I have hope.

On a side note: she did say that since my machine was out of warranty that I would be out of luck when it did quit working but that she would continue to "research" to help me to get it to cut if her suggestions did not work.

All of this to say that for some weird reason perseverance and a new mat seems to have solved my problem. I have only made about 10 cuts on it so who knows, it could quit tomorrow but for now, yay!!!!!

Blessings,
Jana
sue4e85811d8 Offline
#6 Posted : Monday, November 12, 2012 12:01:46 PM(UTC)
sue4e85811d8

Rank: Advanced Member

Groups: Registered
Joined: 11/28/2011(UTC)
Posts: 40
United Kingdom

Was thanked: 9 time(s) in 8 post(s)
I live in the UK and have been following all the posts regarding the Imagine. I must admit I am very reluctant to update my Imagine or any of my other machines as I did encounter a problem when I updated my Gypsy, Create and Expression 2. I was told by someone on the message board to take my Create back to a previous version and it worked. I must also confess that I do not link up to Cricut Craft Room but only use my Gypsy with my Imagine and Expression 2 (it doesn't like my Create anymore! I have decided that due to all the problems I am not buying any more new cartridges as I am concerned I may have to update my machines to use them. From now on I shall use my Imagine and E2 (and I love both)with the Gypsy and use the Create just with cartridges and never update again!
Bri.Johnson07 Offline
#7 Posted : Tuesday, November 13, 2012 6:37:07 PM(UTC)
Bri.Johnson07

Rank: Member

Groups: Registered
Joined: 5/30/2012(UTC)
Posts: 10

Was thanked: 1 time(s) in 1 post(s)
I think my imagine is doing the same that yours did, I'm not sure, I really dont know what happened to it, if it was an update, or what, one day it was working fine the next I was working in CCR and it wouldnt work, said it needed an update, and that my machine needed to be updated, ever since then it's not working, when I try to simply connect to the sync, it will not do it, and the lady wont email me back anymore either....
Bri.Johnson07@gmail.com
Khrista Offline
#8 Posted : Tuesday, November 13, 2012 11:03:48 PM(UTC)
Khrista

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Circle Member, Registered
Joined: 5/12/2010(UTC)
Posts: 5,356
United States
Location: Southwest Washington State

Thanks: 1443 times
Was thanked: 2508 time(s) in 1396 post(s)
Originally Posted by: bri.johnson076804b73a Go to Quoted Post
I think my imagine is doing the same that yours did, I'm not sure, I really dont know what happened to it, if it was an update, or what, one day it was working fine the next I was working in CCR and it wouldnt work, said it needed an update, and that my machine needed to be updated, ever since then it's not working, when I try to simply connect to the sync, it will not do it, and the lady wont email me back anymore either....
Bri.Johnson07@gmail.com


I know some people ran into a driver issue when they updated. I would call PC and they can help you figure it out and if need be (and you give them the permission to do so) take over your computer to troubleshoot the issue.

HTH
:)Khrista
lptollette02e31867 Offline
#9 Posted : Wednesday, November 14, 2012 6:19:30 AM(UTC)
lptollette02e31867

Rank: Advanced Member

Groups: Registered
Joined: 10/18/2012(UTC)
Posts: 31

Thanks: 1 times
Was thanked: 7 time(s) in 4 post(s)
Originally Posted by: JanaBailey Go to Quoted Post
Update~The customer service person that emailed me the bad link stopped replying to my emails. Left me high and dry with no link at all. I was so disappointed, I usually get really go cs when I call. So I felt that I had to tackle the whole thing again.

So....
after hours and hours, even days of experimenting and trying to get my I to cut again, it is finally working. I ran the restore two more times until it made it through the process without getting stuck. It still wasn't cutting so I tried cutting again with CCR and it didn't work but then I thought I would try using my Gypsy and it actually CUT!

I thought it was strange and realized that if it could cut with the gypsy it HAD to be able to cut alone, so I again called PC and talked with a new person that kept urging me to buy new mats even after I told her that I had good, clean mats and then she suggested that I take my machine and use another computer to run the restore on it. I didn't want to do that so I thought I would "appease" her by going and buying new mats just to be able to say I tried it and it didn't work. But guess what???? So far, it is cutting in CCR, alone and with my Gypsy. She said that she thought the machine was having a hard time recognizing the mat so I needed to try a new one. Thanks you Kaila Christenson!!!! I have hope.

On a side note: she did say that since my machine was out of warranty that I would be out of luck when it did quit working but that she would continue to "research" to help me to get it to cut if her suggestions did not work.

All of this to say that for some weird reason perseverance and a new mat seems to have solved my problem. I have only made about 10 cuts on it so who knows, it could quit tomorrow but for now, yay!!!!!

Blessings,
Jana


I've learn that the new mat must have black line near the edge for imagine.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.436 seconds.
nebo-cricut-01