• Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.



creative-confections12035174 Offline
#1 Posted : Sunday, December 02, 2012 8:34:26 AM(UTC)

Rank: Newbie

Groups: Registered
Joined: 12/2/2012(UTC)
Posts: 1

Help! I was trying to use the CCR for the first time, (I just got my mchine on Nov. 28th)I was ready to cut and it said I needed a new version of firmware. So I start to downlad it make it thru step one and step two. But when it gets to step three, nothing happens. The cricut restarts itself and i put it in download mode but nothing starts to happen.... What am i doing wrong?!
guiderjen9d9a06e1 Offline
#2 Posted : Thursday, December 06, 2012 9:38:23 AM(UTC)

Rank: Newbie

Groups: Registered
Joined: 12/3/2012(UTC)
Posts: 5

Thanks: 1 times
Was thanked: 2 time(s) in 2 post(s)
I actually had the exact same problem just the other day. I called customer support and this is how we fixed it. She told me to downloud Design studio and once it was downlouded to go the "Help" icon and downlod firmware updates. THat took me from my 1.31V to 1.34V. So from there I should have been able to download teh new firmware in CCR but it still wouldn't work. I uninstalled CCR (but not design studio) and then reinstalled it and then did the firmware update. It worked like a charm.

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2015, Yet Another Forum.NET
This page was generated in 3.626 seconds.