Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

joshuabonnett3c78d968 Offline
#1 Posted : Friday, December 07, 2012 7:50:04 PM(UTC)
joshuabonnett3c78d968

Rank: Member

Groups: Registered
Joined: 1/4/2012(UTC)
Posts: 14

Thanks: 6 times
Was thanked: 1 time(s) in 1 post(s)
Hi all -

No matter how light or how hard I push when loading my Imagine mat - the first time it pulls it all the way through- and spits it out. I put it back in the second time and it prints and cuts fine. Not a detrimental issue - but it's frustrating. Any ideas on how to fix?
JanaBailey Offline
#2 Posted : Thursday, December 20, 2012 4:08:37 PM(UTC)
JanaBailey

Rank: Advanced Member

Groups: Registered
Joined: 5/11/2006(UTC)
Posts: 472
Location: Texas

Thanks: 58 times
Was thanked: 169 time(s) in 110 post(s)
Sorry no one has replied. I have the same problem but mine doesn't spit it out, it just says "mat not recognized "retry". It always works the second time but yes, very frustrating, especially when cutting out 5000 circles!!!!!
Hope you get it figured out :)
Blessings,
jana
 1 user thanked JanaBailey for this useful post.
joshuabonnett3c78d968 on 12/23/2012(UTC)
Connie Offline
#3 Posted : Wednesday, December 26, 2012 10:20:15 PM(UTC)
Connie

Rank: Newbie

Groups: Registered
Joined: 2/6/2012(UTC)
Posts: 1
United States

I'm having the same issue. When I press Go, the mat pulls all the way thru and back out the front. It will sit there for a minute or two and then spit mat out without cutting. Very frustrating. I guess I'll try to call PC. My work schedule makes it hard to catch them. I would love to know if you find a fix.
Khrista Offline
#4 Posted : Thursday, December 27, 2012 1:26:12 AM(UTC)
Khrista

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Registered, Circle Member
Joined: 5/12/2010(UTC)
Posts: 5,360
United States
Location: Southwest Washington State

Thanks: 1444 times
Was thanked: 2510 time(s) in 1398 post(s)
I'd make sure your machine is up to date. Also make sure the black lines are not covered at all. Try inserting the mat the opposite direction and/or try another mat. Sometimes it's a bad mat. Sometimes it's a particular cartridge. Also depends if you are using Cricut CraftRoom. If you are, then odds are it is CCR and not the Imagine. CCR often spits the mat out and people have to put it in again. PC has stated that they'll support the Imagine as a stand alone machine. I know people have called and gotten some limited help in trying to get CCR to work correctly with their machine, but still is hit and miss on who it works perfect for, who has mats spit out, who has mats go in and spit out then the machine starts to cut w/o a mat, and who it doesn't work for at all. :)

:)Khrista
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.369 seconds.
nebo-cricut-02