Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

Radbunny Offline
#1 Posted : Saturday, January 12, 2013 7:34:23 PM(UTC)
Radbunny

Rank: Advanced Member

Groups: Registered
Joined: 10/28/2006(UTC)
Posts: 130
Location: Arkansas

Thanks: 58 times
Was thanked: 50 time(s) in 34 post(s)
OK, don't judge me, but I haven't used my Gypsy in over a year... almost 2 yrs, actually. When I moved here a year ago, I lost the power cord. So last summer when I turned it on, it was dead, of course. I finally got around to getting the power cord with my rewards (yay!) and it has been charging today. I saw the Gypsy screen come up and set it aside to charge.

Just a few min ago, I grabbed it to start playing again and nothing. The blue light is on, but I can't get the screen to turn on. Am I missing something? (It has been a LONG time!) I can't get it to turn off either!! So I'm stuck with a pretty blue light and blank screen.

Any suggestions??

Thanks!! :)
Shauna
jnjdominguez88 Offline
#2 Posted : Sunday, January 13, 2013 3:57:01 PM(UTC)
jnjdominguez88

Rank: Newbie

Groups: Registered
Joined: 5/8/2009(UTC)
Posts: 3
Location: Chicago,IL

Thanks: 2 times
Was thanked: 1 time(s) in 1 post(s)
Originally Posted by: Radbunny Go to Quoted Post
OK, don't judge me, but I haven't used my Gypsy in over a year... almost 2 yrs, actually. When I moved here a year ago, I lost the power cord. So last summer when I turned it on, it was dead, of course. I finally got around to getting the power cord with my rewards (yay!) and it has been charging today. I saw the Gypsy screen come up and set it aside to charge.

Just a few min ago, I grabbed it to start playing again and nothing. The blue light is on, but I can't get the screen to turn on. Am I missing something? (It has been a LONG time!) I can't get it to turn off either!! So I'm stuck with a pretty blue light and blank screen.

Any suggestions??

Thanks!! :)
Shauna




Maybe it won't work again! I have been using my gypsy, when I was about to plug it to my cricut the USB pops inside, I called Provo craft and they don't have a repair shop and basically I'm screwed! My screen now doesn't wanna turn on and I'm pist cuz hw will they know what carts I had synced on there! So good luck with that!
Radbunny Offline
#3 Posted : Sunday, February 17, 2013 1:39:24 PM(UTC)
Radbunny

Rank: Advanced Member

Groups: Registered
Joined: 10/28/2006(UTC)
Posts: 130
Location: Arkansas

Thanks: 58 times
Was thanked: 50 time(s) in 34 post(s)
Oh man! That stinks!! :( Now I'm really disappointed. I'm finally in a place where I have time to sit and play on the Gypsy, and I can't. figures.

Do you think ProvoCraft will ever figure out the Customer Service side of business?? I remember when the Cricut first came out and everything was GREAT! I think they turned commercial, cranked out too many products and quality and customer service faltered. Too bad.

I still love my Cricut, though. I'm just not happy with the way things are going all digital lately...

Guess I'll store my Gypsy right back into the pretty box it came in...
Sherri Kay Offline
#4 Posted : Monday, February 18, 2013 5:20:54 PM(UTC)
Sherri Kay

Rank: Advanced Member

Groups: Registered
Joined: 1/9/2010(UTC)
Posts: 6,764
United States
Location: Minnesota

Thanks: 430 times
Was thanked: 2408 time(s) in 2160 post(s)
Before giving up completely, you should give PC a call and see if there are any resetting procedures you can try. Especially before putting it away for good and thinking it's not working when it could possible just need a reset. It's worth a try. Unsure
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.587 seconds.
nebo-cricut-02