Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

Benson1268adc567 Offline
#1 Posted : Wednesday, January 30, 2013 6:40:08 PM(UTC)
Benson1268adc567

Rank: Newbie

Groups: Registered
Joined: 5/8/2012(UTC)
Posts: 1

i just purchased an expression2 the cutting blade is installed as described yet it is barely nicking the paper.
Nancy J. Offline
#2 Posted : Wednesday, January 30, 2013 9:26:36 PM(UTC)
Nancy J.

Rank: Advanced Member

Groups: Registered
Joined: 11/10/2011(UTC)
Posts: 160

Thanks: 14 times
Was thanked: 113 time(s) in 71 post(s)
Benson, I usually have my green blade housing set at 4,5, or 6 to cut most things. Hope this helps... but if it doesn't you can always call Cricut Support and they will help you figure out why it isn't working right for you and their number is listed under SUPPORT/contact us.
MarleneO Offline
#3 Posted : Wednesday, January 30, 2013 9:43:16 PM(UTC)
MarleneO

Rank: Advanced Member

Groups: Registered
Joined: 12/21/2008(UTC)
Posts: 385
United States
Location: USA

Thanks: 7 times
Was thanked: 103 time(s) in 80 post(s)
Check that the housing is exactly where it should be. When I got my first expression, I installed the housing wrong and it wouldn't cut anything until I realized my mistake. Good Luck!
paula_bee Offline
#4 Posted : Thursday, January 31, 2013 9:33:34 AM(UTC)
paula_bee

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Circle Member, Registered
Joined: 2/22/2009(UTC)
Posts: 4,131
Location: Minnesota

Thanks: 2208 times
Was thanked: 2305 time(s) in 1669 post(s)
On a new machine the blade depth is usually set at 1, which won't cut most things. You need to have the blade depth set at 3 or 4 to cut basic cardstock. Also be sure your pressure setting is not too low either.
LD Offline
#5 Posted : Tuesday, February 05, 2013 7:16:08 PM(UTC)
LD

Rank: Newbie

Groups: Registered
Joined: 8/17/2007(UTC)
Posts: 1
Location: Ohio

I just opened my E2 and I am having the same problem...tried changing the blade...that didn't work....guess my next step will be a phone call.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.495 seconds.
nebo-cricut-02