Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

jdschultzfa0dfc8c Offline
#1 Posted : Tuesday, March 26, 2013 10:05:30 AM(UTC)
jdschultzfa0dfc8c

Rank: Newbie

Groups: Registered
Joined: 1/3/2012(UTC)
Posts: 1

Okay this is my first post here. I have tried to update my imagine and tried to reset it and nothing is working. I just brought the Boys will Be Boys cartridge and when I put it in my Imagine it told me to update....well I guess that was my mistake, went to Cricut sync and it started to update got to the first part and said the Imagine will start itself, well it wont start. It just goes to the start up screen which says Cricut Imagine and won't go any further. This is getting bad. It worked before with the cartridges I had with the exception of Kate's Alphabet which have returned twice to the store because the screen said couldn't read, lost money there, and now it seems that the whole machine is a lost.

Anybody have any idea? Have done research but even the link to reset, sticky on top of threads, doesn't work and the direct link to the update doesn't work!!

Please help, oh and I've only used this machine a few times, so not worth the fustration!!

Thanks in advance for any advice.

Angie
Maxluv Offline
#2 Posted : Tuesday, March 26, 2013 10:18:49 AM(UTC)
Maxluv

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Registered, Circle Member
Joined: 12/27/2010(UTC)
Posts: 2,238
United States
Location: Baltimore MD

Thanks: 43 times
Was thanked: 490 time(s) in 377 post(s)
You can always call the Support desk for some assistance. Click on Support at the bottom of the page.
Khrista Offline
#3 Posted : Wednesday, April 03, 2013 11:42:57 AM(UTC)
Khrista

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Registered, Circle Member
Joined: 5/12/2010(UTC)
Posts: 5,358
United States
Location: Southwest Washington State

Thanks: 1445 times
Was thanked: 2512 time(s) in 1400 post(s)
Sounds like the update didn't go through. I'd call support. You may have to format and I'd keep them on the line while you do so.

and If you're up to date, then odds are it is another cartridge that the machine is not recognizing. There's about 20 cartridges that the machine won't recognize. It's been that way for over a year. Usually the problem is when you're using a Gypsy or CCR. I'd call PC since they say they'll continue to 'support' the Imagine.

:)Khrista
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.358 seconds.
nebo-cricut-04