Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

heidi_lyn_tucker2f337b7c Offline
#1 Posted : Saturday, April 06, 2013 3:39:56 PM(UTC)
heidi_lyn_tucker2f337b7c

Rank: Newbie

Groups: Registered
Joined: 4/6/2013(UTC)
Posts: 1

So, I just moved and my cricut usually stays in the box when I am not using it. I took it out to use it and the power wouldn't turn on. The green light is on the power cord. I tried hitting the red reset button but nothing happened. When I went to move the blade housing back, I saw the lights on my Cricut light up. Does anyone know what's going on and how to fix it. I have some projects I need to do ASAP for a wedding!

Thank You,

Heidi
CricutGena Offline
#2 Posted : Saturday, April 06, 2013 8:37:34 PM(UTC)
CricutGena

Rank: Advanced Member

Groups: Registered
Joined: 3/28/2011(UTC)
Posts: 972

Thanks: 4 times
Was thanked: 999 time(s) in 320 post(s)
Hello! It would be difficult to tell what may have happened over the message boards. Please call customer service at 877-7cricut. We can help you over the phone.

-Cricut Gena
GypsyBoricua Offline
#3 Posted : Sunday, April 07, 2013 9:06:44 AM(UTC)
GypsyBoricua

Rank: Advanced Member

Groups: Registered
Joined: 5/6/2010(UTC)
Posts: 1,278

Thanks: 1230 times
Was thanked: 886 time(s) in 488 post(s)
I had this happen to me on my Create. Even though the green light was on in the power cord, there was still something wrong with it. If you have another Crict, the cords are interchangeable. Try that and see.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.443 seconds.
nebo-cricut-03