• Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.



2 Pages<12
dori158858376ba0 Offline
#31 Posted : Sunday, December 15, 2013 3:17:17 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 10/24/2013(UTC)
Posts: 3

I'm very angry that we haVE TO GO THROUGH THIS. everyone knew Mavrick was coming. Why didn't Cricut prepare for its arrival? I have been on the phone with Cricut at least once a week, since before Thanksgiving looking for an update, all I'm ever told is that they are working on the issue. I'v never had any suggestions on how i might be able to fix the issue. I missed making my thanksgiving decorations and don't even get me started on Christmas. Most of my stuff is digital ,I'm out of luck. i feel like a wasted all my money on this stuff. every week I'm told we'll email you when the problem is corrected. I'm tired of waiting.Angry
abmartin1d5cee51 Offline
#32 Posted : Tuesday, December 24, 2013 8:47:38 AM(UTC)

Rank: Newbie

Groups: Registered
Joined: 12/24/2013(UTC)
Posts: 1

I'm so disappointed right now in my CE. I have been using my cricut with SCAL so I could cut out SVG's and finally upgraded to a Silhoutte so I could use CCR since it looks so cool. I've been trying to upgrade my Firmware and I am having no luck. I have followed your wonderful detailed instructions 2 times and all it does is make my cricut stuck in update mode....so frustrating I don't know what to do and it doesn't sound like Cricut support is very helpful. I am so thankful I purchased that Silhoutte so at least I can cut stuff out.
julie.shields.phx44c831f1 Offline
#33 Posted : Sunday, January 26, 2014 8:12:58 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 1/26/2014(UTC)
Posts: 1

I am a PC user and was having the same issues. After doing some research, I realized that I needed to update my CCR for Windows 8.1. If you are using Windows 8.1 – please go to this link for a Windows 8.1 update FIRST, then follow the steps in the initial post.
MairaCenzi Offline
#34 Posted : Tuesday, January 28, 2014 3:39:39 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 7/28/2011(UTC)
Posts: 3

Thanks: 1 times
Was thanked: 2 time(s) in 1 post(s)
Angry Well I'm trying to update this since last year and still nothing.
The problem is that I'm from Brazil and my english is not so good and I can't call to costume service.
I'm still waiting for solution. Mad
baccsurfs4e96f071 Offline
#35 Posted : Monday, February 03, 2014 6:42:36 PM(UTC)

Rank: Member

Groups: Registered
Joined: 1/22/2014(UTC)
Posts: 15

Was thanked: 9 time(s) in 5 post(s)
Crying I was having this problem. Called support directed me to cricut design studio which still didn't work. I had to send photo of machine stuck in update mode. They sent me directions for disabling the machine so they could send me a new one. I am sick over this and was near tears waiting on hold for support the second time after the fix didn't work. I had to send photos of the machine disabled per their instructions and now need to wait for them to verify receipt of that and send me the new machine. Needless to say, I will not be connecting my new expression to the craft room. I don't want to go through this again. Cartridges only for this girl! I have only had this machine a few weeks and I was hoping since I finally got my other supplies (paper, cartridges, etc.) to get started tomorrow on Memory Albums for me and my siblings of my Mom who we lost in November. Now it will be delayed at least another week! This experience has made me even more skeptical of the Explore since it relies on an internet based program. Not that I could afford that type of upgrade anytime in the near future!
 1 user thanked baccsurfs4e96f071 for this useful post.
mike4dawndfcfff87 on 1/8/2015(UTC)
cricutf8416877 Offline
#36 Posted : Sunday, February 09, 2014 6:45:36 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 2/9/2014(UTC)
Posts: 1

Don't give up! After spending literally ALL day fighting with my machine and scanning the internet for help, I finally got my Expression working again. Whew, what a time suck figuring this out.

I don't know which was the important component, but here is what I tried.

I did use the trial version of Cricut Design Studio to do the first firmware update. It said I needed to do a second update but I couldn't get it to do that. So, I went back to Cricut Craft Room to try again from there. The key thing, I think, was a mention in a post somewhere to update Cricut Craft Room to Windows 8.1 for PC. http://www.cricut.com/home/usemini Once I did that and went through all the firmware update steps again it finally worked. Whooohooooooo!

My expression is cutting hearts just in time for Valentine's Day. Thankfully the cartridges I have are not totally useless. I'm not so sure I'll ever try to hook up to the computer to use Design Studio or Cricut Craft Room in the future. I think I may just stick to the cartridges so this doesn't ever happen again.

Good luck to others who have struggled!

WendyKing2 Offline
#37 Posted : Friday, March 07, 2014 7:08:57 AM(UTC)

Rank: Newbie

Groups: Registered
Joined: 9/26/2011(UTC)
Posts: 1

Patience....this is something I never thought I had BUT after 48 hours of trying to upload the firmware on MAC and PC and both and not getting anywhere I called Cricut.com...they didn't know what was happening. Offered to replace the machine.

I had the display on Expression saying it was 2.43 but the Mac wasn't recognizing it. I did everything in each one of the posts you lovely, kind women had posted in trying to help others not go through the frustration that you did.

I just decided to try something totally new. So...I uninstalled the CDS and just plugged in Cricut to cut on PC without the CDS and no downloads, etc. Pretended all was normal and hit cut....

IT CUT.....

So, my looooooong battle is over. I will NOT be using CCR with my brand new (well 6 months old, but still brand new in my non techy eyes) and just on the old crappy laptop we have had for 11 years....another reason why I love vintage.

thanks for the help ladies...Love Love
kelmoo25a689ab4 Offline
#38 Posted : Saturday, December 27, 2014 1:12:06 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 12/27/2014(UTC)
Posts: 1

HELP NEEDED!!! I have a Cricut Expression and only use cartridges to cut shapes etc. I bought a new cartridge awhile back and the machine would not recognize it. So I read online how I needed to update my firmware. I installed CCR to my sister's computer, followed the directions and updated the machine. Problem is now no matter what cartridge I put in, it will only cut George and Basic Shapes. Any suggestions???

I have a Cricut Personal cutter but would love to cut smaller than 1" and bigger than 5.5" so any help would be appreciated.

Thank You!!
k_v_kelley4f9cb5d7 Offline
#39 Posted : Sunday, May 03, 2015 9:18:37 AM(UTC)

Rank: Newbie

Groups: Registered
Joined: 5/3/2015(UTC)
Posts: 2

We were having the same firmware update download problem that others were having. We would get to the point of download and the process would hangup. I looked in the Explorer menus and realized the popup blocker was on. Once turned off, the down finished in less than two minutes. [if command bar is not on right click menu bar and enable, click tools, click popup blocker to disable, return to download, refresh page.]Glare
Users browsing this topic
Guest (2)
2 Pages<12
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2015, Yet Another Forum.NET
This page was generated in 5.375 seconds.