• Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.



hlmanuel623f13f75fa Offline
#1 Posted : Tuesday, August 12, 2014 8:47:54 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 8/12/2014(UTC)
Posts: 1

I have had my cricut create for about 2 months now. I loved it, until today. I hooked it up to my computer to try out the CCR and it updated my firmware. Now it wont let me do anything. I tried to reset it back to factory by doing what it said to do online. I pressed the red button, moved the dials up and down three times and turned it off. I have tried this about three or four times today and its just not doing anything. The first time I tried I left it off for about 20 min just like it said. Still nothing, I tried it again and left it off for over an hour. Same with the third time. This last time I did it, I just unplugged it and put it away for the night. Is there something I can do to get the firmware back to 1.51 like it was up until CCR updated it? Any help would be great.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2015, Yet Another Forum.NET
This page was generated in 0.594 seconds.