• Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.



JodySmith Offline
#1 Posted : Monday, January 02, 2012 11:46:40 AM(UTC)

Rank: Newbie

Groups: Registered
Joined: 1/1/2008(UTC)
Posts: 1

I was unable to register my Art Philosophy cartridge and am wondering if I will have trouble loading it into my gypsy. I am updating my gypsy now so hopefully I will be able to use them together. My main question right now is whether or not I am missing something on the registering page or is this particular cartridge not on the list yet?
Terry Offline
#2 Posted : Saturday, January 07, 2012 6:29:23 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 1/7/2012(UTC)
Posts: 1
United States

Thanks: 1 times
I'm trying to figure this out too! I got mine in October 2011 and tried loading it didn't work. Tried updating my gyspy software and it still didn't work. Trying it again tonight. It's taking forever to load the Gypsy software, don't remember it taking this long when I got my gypsy. I've heard we need to call Cricut to get a replacement Art Philosophy cartridge if it doesn't load.
RockinRenee Offline
#3 Posted : Sunday, February 05, 2012 10:22:34 AM(UTC)

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Registered, Circle Member
Joined: 10/26/2009(UTC)
Posts: 5,772
United States
Location: Frisco, TX

Thanks: 7425 times
Was thanked: 4457 time(s) in 1952 post(s)
Mine didn't load either, but once I updated the latest firmware for my machines and gypsy, everything worked fine.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2015, Yet Another Forum.NET
This page was generated in 0.908 seconds.