Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

jsaphara25edc989 Offline
#1 Posted : Saturday, January 28, 2012 12:50:42 PM(UTC)
jsaphara25edc989

Rank: Newbie

Groups: Registered
Joined: 1/28/2012(UTC)
Posts: 2

I have the Cricut Personal Cutter - have only used several times. It would not power on the other day, have replaced the power cord, no when the machine powers on it hums and only displays a portion of the display board. I tried resetting it as suggested on other boards, but no luck. Any ideas on how to fix this??
okstout4352affda Offline
#2 Posted : Thursday, February 02, 2012 10:03:14 AM(UTC)
okstout4352affda

Rank: Member

Groups: Registered
Joined: 1/17/2012(UTC)
Posts: 23

Thanks: 8 times
Was thanked: 2 time(s) in 2 post(s)
I got my machine before Christmas and *knocking on wood* have not had or heard of issues like this. If it were me, I'd get it replaced. Mine doesnt make noise (other than the taking in of the mat and cutting) and my screen is just fine. Occasionaly, I do have to turn it off and back on, but no other issues. There is a limited warranty, but my book doesnt go into detail about it...only states "limited warranty". The number for help is 1-877-727-4288. I hope this helps and I hope you can get it replaced. After 2 uses, this should not be doing this....or after any number of uses. Good luck!
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.240 seconds.
nebo-cricut-01