Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

Joan Doretta Offline
#1 Posted : Saturday, September 25, 2010 6:17:18 AM(UTC)
Joan Doretta

Rank: Advanced Member

Groups: Registered
Joined: 11/8/2007(UTC)
Posts: 33
Location: Wisconsin

Was thanked: 8 time(s) in 4 post(s)
Angry What do you do to fix your blade dragging? I have so many extra cuts, and I don't know what to do.
Thanks to all who take the time to reply.
Joan
CarolS Offline
#2 Posted : Saturday, September 25, 2010 8:10:14 AM(UTC)
CarolS

Rank: Advanced Member

Groups: Registered
Joined: 8/21/2009(UTC)
Posts: 341
United States
Location: SE Coastal Georgia

Thanks: 16 times
Was thanked: 102 time(s) in 50 post(s)
Not exactly sure what you mean by blade dragging but if you mean it drags across on the machine than you have the blade setting too low to the machine such as a 6 which is closest to the machine, 5 a little higher, 4 a little higher than a 5, etc.

Also depends what you are cutting causing it to drag and where you have it set at for blade setting.
PattyGolden Offline
#3 Posted : Saturday, September 25, 2010 8:14:06 AM(UTC)
PattyGolden

Rank: Advanced Member

Groups: Registered
Joined: 1/27/2008(UTC)
Posts: 122
Location: NW Ohio

Thanks: 11 times
Was thanked: 210 time(s) in 25 post(s)
i've read about this here in the past and i believe what worked for some is to reset the machine. Here's how you do it.

good luck! i think there are other solutions, so come back here if this doesn't work for you!
CherylfromOz Offline
#4 Posted : Saturday, September 25, 2010 10:18:42 PM(UTC)
CherylfromOz

Rank: Advanced Member

Groups: Registered
Joined: 6/15/2007(UTC)
Posts: 1,815
Australia
Location: Queensland Australia

Thanks: 266 times
Was thanked: 250 time(s) in 155 post(s)
have you removed your blade from the housing, blow out the housing, sometimes there is stuff in there that makes you blade do funny things

hope this helps
DoodleBug2 Offline
#5 Posted : Monday, September 27, 2010 3:29:54 PM(UTC)
DoodleBug2

Rank: Advanced Member

Groups: Registered
Joined: 1/14/2009(UTC)
Posts: 597
Location: Idaho

Thanks: 294 times
Was thanked: 119 time(s) in 113 post(s)
Also make sure the blade is in its housing correctly and that it is tightened down. HTH. Mine didn't something similar to that and the housing had wiggled loose after a lot of cutting.
~LN Offline
#6 Posted : Tuesday, September 28, 2010 7:15:48 PM(UTC)
~LN

Rank: Advanced Member

Groups: Registered
Joined: 3/22/2009(UTC)
Posts: 2,911
United States

Thanks: 1292 times
Was thanked: 881 time(s) in 734 post(s)
I have had this same problem..if it is what I think you are saying..rough cuts along some of the edges?


I reset my machine and now ot cuts like butterCool
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.259 seconds.
nebo-cricut-01