• Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.



raffababyd3543270 Offline
#1 Posted : Friday, September 21, 2012 7:41:23 AM(UTC)

Rank: Newbie

Groups: Registered
Joined: 9/21/2012(UTC)
Posts: 1


I bought my cricut 4 days ago and i cannot install drivers via CDS. My Computer tells me that the current language is not supported by the device driver installation wizard.

So i don´t know what to do. 2 Days ago i have installed the CDS to my laptop and everything worded fine. I live in germany.

i hope someone can help me

mommyto3bugs Offline
#2 Posted : Monday, October 08, 2012 1:39:00 AM(UTC)

Rank: Advanced Member

Groups: Registered
Joined: 1/16/2007(UTC)
Posts: 47
Location: Here

Thanks: 178 times
Was thanked: 30 time(s) in 13 post(s)
Are you trying to install it on a PC? Which Windows version are you using on that computer? Are you installing from a disk for from the download from the site? If you know what drivers you need you might be able to copy them (just the drivers) from the laptop onto the other computer.
christavanaken0a7d5aad Offline
#3 Posted : Monday, October 15, 2012 1:21:12 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 10/15/2012(UTC)
Posts: 3

Hi all,
Same problem here. Update worked well on one laptop + cricut, but is giving the language probem on another laptop + another cricut (laptops are identical twins, cricuts both had/have v1.0 firmware).
How to proceed?
christavanaken0a7d5aad Offline
#4 Posted : Friday, October 19, 2012 2:00:06 AM(UTC)

Rank: Newbie

Groups: Registered
Joined: 10/15/2012(UTC)
Posts: 3

Here's what worked for me.

We installed Cricut Design Studio.
Do not register, just use the trial version.
From the helpmenu, update the firmware. It will update from 1.0 to 1.1.

Now install (or open) Cricut Craft Room.
From the helpmenu, choose Install Drivers, then choose 'Personal Cutter' and follow the instructions.

This updated our firmware to 1.34.

For linking cartridges you need 1.40, but older machines can't handle that yet :-(.

Edited by user Friday, October 19, 2012 2:02:01 AM(UTC)  | Reason: Missing '

christavanaken0a7d5aad Offline
#5 Posted : Saturday, October 27, 2012 4:35:16 PM(UTC)

Rank: Newbie

Groups: Registered
Joined: 10/15/2012(UTC)
Posts: 3

A bit off topic, but following up on my latest post: as of oktober 18, there is a new firmware version for our old machine that allows linking cartridges. Good work Provocraft!
Hello Kitty Offline
#6 Posted : Monday, July 15, 2013 9:27:30 PM(UTC)
Hello Kitty

Rank: Newbie

Groups: Registered
Joined: 8/16/2010(UTC)
Posts: 2
Location: Australia

Thanks: 6 times
Was thanked: 1 time(s) in 1 post(s)

I know you asked this quite some time ago...but just found the solution. I also had the same issue, and anyway, eventually solved it myself. So here's how:

Go to Device Manager.. You'll see a device with the yellow ! (exclamation mark) after it, that's called USB -> Serial. Right click and select update driver. Make sure you have windows set up for automatic downloads (this is in the windows updates area). As soon as this updated, my Cricut (expression), was detected straight away when I ran the Cricut Craft Room program again.

Hope this works for you too! If anyone has any queries on this, please feel free to post a reply.

Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2015, Yet Another Forum.NET
This page was generated in 1.372 seconds.