Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

queenjj Offline
#1 Posted : Saturday, September 25, 2010 10:45:29 PM(UTC)
queenjj

Rank: Newbie

Groups: Registered
Joined: 6/6/2010(UTC)
Posts: 8
Location: Eastern WA

Thanks: 7 times
Was thanked: 2 time(s) in 2 post(s)
Tonight my Expression wouldn't turn on so I did a reset and was able to cut about 3 sheets of 12x12 and then it powered off. I can't get it to turn back on. When I unplug it and start a reset and move the knife, lights come on even with it un-plugged. Has anyone else ever seen this? Any ideas? I'd appreciate any help. I ned to do some cutting. This is only the fourth time I haved used it. Thank you in advance.
CherylfromOz Offline
#2 Posted : Saturday, September 25, 2010 11:13:54 PM(UTC)
CherylfromOz

Rank: Advanced Member

Groups: Registered
Joined: 6/15/2007(UTC)
Posts: 1,815
Australia
Location: Queensland Australia

Thanks: 265 times
Was thanked: 249 time(s) in 154 post(s)
Sorry if you have already done the reset then all I can suggest is call PC hope they can help
 1 user thanked CherylfromOz for this useful post.
queenjj on 9/30/2010(UTC)
toaster Offline
#3 Posted : Sunday, September 26, 2010 5:08:01 AM(UTC)
toaster

Rank: Advanced Member

Groups: Registered
Joined: 1/4/2008(UTC)
Posts: 217

Thanks: 3 times
Was thanked: 41 time(s) in 34 post(s)
I have been having this problem with my baby bug for a while. I thought it was the power cord but I think it is the on/off button. I can get the machine to turn on (atleast so far) but sometimes I press the button 10 or more times. I can see the machine is getting power because the blade housing vibrates. I called PC and didn't really get any help.I have reset the machine a few times. I don't think there is much more that can be done since the machine is out of warranty and PC doesn't repair. I hope your machine is under warranty. I wish I could have helped you more.
 1 user thanked toaster for this useful post.
queenjj on 9/30/2010(UTC)
queenjj Offline
#4 Posted : Thursday, September 30, 2010 4:35:51 PM(UTC)
queenjj

Rank: Newbie

Groups: Registered
Joined: 6/6/2010(UTC)
Posts: 8
Location: Eastern WA

Thanks: 7 times
Was thanked: 2 time(s) in 2 post(s)
It seems like it is over powering so if I unplug it and leave it be, it seems to come back to life. Thanks for the advice and information.
JD
cosmos Offline
#5 Posted : Monday, October 04, 2010 11:18:58 AM(UTC)
cosmos

Rank: Advanced Member

Groups: Registered
Joined: 8/11/2006(UTC)
Posts: 108

Thanks: 41 times
Was thanked: 37 time(s) in 22 post(s)
I had a similar problem with my E power off immediately after I would turn it on and it would so through it's little (pre-set up) then shut down. This did not happen until I connected to my Gypsy.

Although my machine had less that 15 hours on it I was so frustrated. Mercy on the forum tried to help but we hade little success. On Monday I called PC and Darin whom is fabulous walked me through a few trouble shooting steps only to determine that it was a glitch in the E. He had me send it back and in a VERY short time I had a new Cricut in my home. Yeah Darin

I was so traumatized that I had done something to cause this and although he reassured me that I had not, when I got my new machine I called him and he walked completely through the Gypsy Sync and helped me get my E and Gypsy up and running.

Call PC they are so awesome, they want happy users. You may have to wait a bit on the phone but when it is your turn they will give you all the time you need to help you through YOUR problem.

Provo Craft Customer Service is awesome.
Ebersole68 Offline
#6 Posted : Monday, October 04, 2010 6:23:08 PM(UTC)
Ebersole68

Rank: Member

Groups: Registered
Joined: 1/18/2010(UTC)
Posts: 19

Was thanked: 20 time(s) in 7 post(s)
Ditto what cosmos said! I had the same issue you're experiencing with my expression. Called PC, sent the machine back and a new one arrived:) Total time without my expression was about two weeks (of course it malfunctioned on a Friday). I'm just happy it was under warranty
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.678 seconds.
nebo-cricut-02