• Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.



Marcia02 Offline
#1 Posted : Tuesday, October 16, 2012 5:27:46 AM(UTC)

Rank: Newbie

Groups: Registered
Joined: 6/14/2012(UTC)
Posts: 1
United States

My Expression worked just fine the last time I used it a month of so ago. Since then, it's been sitting on my shelf, covered to keep dust off.

Just last night I pulled it out to use it and it was acting goofy. It didn't seem to recognize the shift button. The shift button would beep and light up when pressed, but the machine wouldn't pull up any of the images the shift button should have pulled up.

I tried the reset, but maybe I did it wrong? After doing the reset, I still wasn't able to cut anything on a shift and then my sizes were all wrong. When cutting something that was supposed to be 6", it would only maybe cut 2".

Any ideas what could be happening?
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2015, Yet Another Forum.NET
This page was generated in 1.107 seconds.