Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

beckkingmm Offline
#1 Posted : Thursday, December 06, 2012 7:01:46 PM(UTC)
beckkingmm

Rank: Newbie

Groups: Registered
Joined: 12/6/2012(UTC)
Posts: 2

I am having trouble with my expression. It wasn't making the greatest cuts, so I changed out the blade. Now it is not going through any paper, it is tearing everything, and bits of paper are getting lodged in the blade housing causing even more trouble. Any suggestions?
Maxluv Offline
#2 Posted : Friday, December 07, 2012 10:03:21 AM(UTC)
Maxluv

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Registered, Circle Member
Joined: 12/27/2010(UTC)
Posts: 2,230
United States
Location: Baltimore MD

Thanks: 43 times
Was thanked: 489 time(s) in 376 post(s)
If its not going thru the paper sounds like you didnt put the housing back in correctly. Did you check that?
beckkingmm Offline
#3 Posted : Friday, December 07, 2012 11:09:37 AM(UTC)
beckkingmm

Rank: Newbie

Groups: Registered
Joined: 12/6/2012(UTC)
Posts: 2

I have taken the housing out and replaced it several times and it is still not cutting correctly. I am resetting the machine now. Maybe now it will work.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.229 seconds.
nebo-cricut-03