Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

Fayrai Offline
#1 Posted : Tuesday, January 08, 2013 12:24:54 PM(UTC)
Fayrai

Rank: Advanced Member

Groups: Registered
Joined: 4/15/2007(UTC)
Posts: 92
Location: South Carolina

Thanks: 3 times
Was thanked: 36 time(s) in 16 post(s)
After using my Imagine a week and half days ago, it is dead. It will not power on. I called CS and they said because it is past the one year warranty( a year and 1 month) unless the power cord is faulty, there is nothing we can do. I am so HURT! One of my new year resolutions was to use my Imagine more. I have only used it a handful of times. It's gone. The power cord lights up and I even used a friends cord but no show for the Imagine. What can I do? Is there anyone out there that I can try to see if they can fix it. Somebody please help. I LOVE MY IMAGINE!!!!!!!!
MarleneO Offline
#2 Posted : Tuesday, January 08, 2013 10:20:26 PM(UTC)
MarleneO

Rank: Advanced Member

Groups: Registered
Joined: 12/21/2008(UTC)
Posts: 385
United States
Location: USA

Thanks: 7 times
Was thanked: 103 time(s) in 80 post(s)
Since the Imagine is half an HP printer, I would call a service that repairs ink jet printers. They MAY be able to help you. It's worth a shot!
BrendaHill1 Offline
#3 Posted : Saturday, March 09, 2013 5:10:28 AM(UTC)
BrendaHill1

Rank: Member

Groups: Registered
Joined: 11/24/2007(UTC)
Posts: 13
United States

Thanks: 1 times
Was thanked: 3 time(s) in 2 post(s)
Sorry to hear about your Imagine. Im starting to have minor problems with mines as well. Afraid that it's only a matter of time before my Imagine goes out. My warranty is out this month. Anyhow, try this link for Cricut fixes. It's kind of a forum for all Cricut problems with may people having same problem as your is having. Takes time to seach through comments and advice. Hope it helps.

http://everhack.blog.atx...2/08/cricut-repair-info/[/url]


Looks like you may have to copy/paste above link. Good luck.


Brenda Hill
Stone Mountain, Ga.
SueKoeferl Offline
#4 Posted : Tuesday, April 30, 2013 8:21:36 PM(UTC)
SueKoeferl

Rank: Member

Groups: Registered
Joined: 9/11/2007(UTC)
Posts: 11

Was thanked: 1 time(s) in 1 post(s)
The same thing happened to me. Hadnt used it for a mth. then went to turn it on nothing. Support
said it might need a new power cord as it is a know issue with it. I also wasnt under warrenty and have mult. cartridges. I wasnt sure I wanted to invest more money if this wasnt the problem/. I asked my husband if there was a way to test the power cord and he did and have found the it was under voltage putout. So today I ordered a new cord. Heres hoping it fixes the problem and dont have any more.
Sue
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.657 seconds.
nebo-cricut-02