Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

k.robichaux7ffc1d94 Offline
#1 Posted : Sunday, February 24, 2013 11:16:47 PM(UTC)
k.robichaux7ffc1d94

Rank: Newbie

Groups: Registered
Joined: 2/24/2013(UTC)
Posts: 2

Hi! I just purchased my E2 and have only been playing with it one day and I am already upset. I have a mac and everything downloaded fine for craft room, but the USB keeps saying it "lost its connection". I am really confused because it is still plugged in? Has anyone else had this problem? The only thing I can think is my apple is wireless in my house and maybe the internet connection is going between my two routers? Any help would be great and I guess I will call support tomorrow too :) Thanks
Narelle Offline
#2 Posted : Monday, February 25, 2013 1:03:40 AM(UTC)
Narelle

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Circle Member, Registered
Joined: 9/26/2006(UTC)
Posts: 10,970
Australia
Location: Facebook: Cricut Lovers Guide to Design Space

Thanks: 2034 times
Was thanked: 7881 time(s) in 3690 post(s)
Have you connected your E2 to Cricut Sync and updated it yet?

If you haven't downloaded Cricut Sync yet here's the link: http://www.cricut.com/home/support/cricut-sync
ChristineCarrizales Offline
#3 Posted : Monday, February 25, 2013 9:54:59 AM(UTC)
ChristineCarrizales

Rank: Member

Groups: Registered
Joined: 11/2/2011(UTC)
Posts: 21

Thanks: 1 times
Was thanked: 5 time(s) in 5 post(s)
Yes. I got an E2 for Christmas and was terribly disappointed until I did the update described above and HOLY COW! after that it cuts like a hot knife in butter-- and every button responds to the first touch!

c.
k.robichaux7ffc1d94 Offline
#4 Posted : Monday, February 25, 2013 9:57:00 PM(UTC)
k.robichaux7ffc1d94

Rank: Newbie

Groups: Registered
Joined: 2/24/2013(UTC)
Posts: 2

I did try and do the update, but it said I have the latest. I will give it a try again. Yes I have been disappointed but not giving up yet! Thanks for the suggestionBigGrin
ChristineCarrizales Offline
#5 Posted : Tuesday, March 12, 2013 8:17:49 AM(UTC)
ChristineCarrizales

Rank: Member

Groups: Registered
Joined: 11/2/2011(UTC)
Posts: 21

Thanks: 1 times
Was thanked: 5 time(s) in 5 post(s)
Hi, Something new happened to me the other day and it reminded me of your post. I got my little airmac pc hooked up to my E2 with the cord, and cut a quick cut-- worked fine-- but then I started a new project and it took a little time... when i went to cut, it said lost connection-- and then, it said it couldn't find the cartridge which was stuck in the machine... I turned the E2 off and on and it came up, connected and all was fine. I think the E2 went to sleep-- and when I turned it off/on, it woke up and re-connected...

c.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.374 seconds.
nebo-cricut-02