• Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.



AprilFloyd Offline
#1 Posted : Tuesday, April 30, 2013 6:53:04 PM(UTC)

Rank: Member

Groups: Registered
Joined: 2/6/2010(UTC)
Posts: 13

Was thanked: 6 time(s) in 3 post(s)
Angry I have been trying to run CricutSync for my Imagine since Thursday! I've gotten several "hits" on the internet suggesting different things to do. I have even tried using two different systems with two different operating systems to see if that would help. Ugh! Here's what I have tried so far:

Windows 7
updated Cricut Craft Room
updated Adobe Air
updated CricutSync

tried cable through usb hub AND directly connected

This system is on a laptop so I thought, maybe it would work better where internet is directly connected so I did the following:

Windows XP
updated Cricut Craft Room
updated Adobe Air
updated CricutSync

cable directly connected to desktop computer

I've even downloaded all files through Windows Explorer instead of Firefox because I was told that might be the issue.

When I run the executable for CricutSync, I get the error "This application cannot be installed because this installer has been mis-configured. Please contact the application author for assistance."

I have Windows Firewall enabled for both Bridge.exe and CricutSync.exe. I have read about CCRBridge.exe but it isn't anywhere on my laptop to allow.

HELP!!!Cursing I'm going crazy trying to figure this out.

Tarella Grossley Offline
#2 Posted : Thursday, May 09, 2013 5:28:16 PM(UTC)
Tarella Grossley

Rank: Newbie

Groups: Registered
Joined: 4/25/2010(UTC)
Posts: 1

I was having the same problem. Once I rebooted the computer it cleared it up and installed successfully. Now, the machine asks for cartridges that I have linked to my account already. I can't get beyond this. And of course I am at work when the office is open.
Khrista Offline
#3 Posted : Thursday, May 09, 2013 9:28:58 PM(UTC)

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Registered, Circle Member
Joined: 5/12/2010(UTC)
Posts: 5,350
United States
Location: Southwest Washington State

Thanks: 1450 times
Was thanked: 2517 time(s) in 1401 post(s)
I need clarification.. are you trying to get Sync to work or Cricut Craft Room?

I'd uninstall sync entirely, reboot, and then reinstall cricut sync. Make sure you don't have a gypsy or anything plugged in at the same time (happens that people do on rare occasion). Depending on your antivirus software, that might be the problem. It's on the cricutsync site how to correct that.

I would also check the white cord. If you happen to have another cord or a printer-USB cord, try switching that out.


Cricut Craft Room - It is hit and miss with the Imagine and Provocraft has stated they will only support the Imagine as a stand alone machine. It's usually not worth the headache to try to get CCR to work.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2015, Yet Another Forum.NET
This page was generated in 1.900 seconds.