Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

robinpurvis322ebe4e9f Offline
#1 Posted : Saturday, October 12, 2013 12:55:44 PM(UTC)
robinpurvis322ebe4e9f

Rank: Newbie

Groups: Registered
Joined: 10/12/2013(UTC)
Posts: 1

I went through so much to get my Cricut (a 2nd one)trying to get it delivered to me as I ended up moving while it was in transit. I finally get it and go buy some vinyl and transfer paper because I want to make some letters and labels, and the machine won't cut a thing. It goes through the motions at least (the first one I got wouldn't cut because the roller bar didn't even touch the mat), but it won't cut. I bought a new housing unit with blade thinking it might be that...but no.

Upon further inspection, I see (after bending over and nearly falling off my chair) that there is some kind of whitish plastic loop sticking out over top of the plastic casing inside over the roller bar area. It looks almost like a hospital band. Now I know of some toys where you have to pull the band in order for them to work...this is what I thought that might be, but I've never heard of anyone talk about having to do that so I did not pull on it.

I received this from a very reputable seller on ebay as a guaranteed machine to work (just like my first one) and contacted them, but they told me to contact Cricut (Provocraft). The first one I tried, the ebay seller refunded me, and I shipped it back. The recent seller is telling me to tell the company. I need someone to help me fix this problem. I have been trying to have this machine for 2 years now and want so much to get started using it for my craft projects. PLEASE SOMEONE HELP!!!!!!!! Thank You!!!

Edited by user Saturday, October 12, 2013 12:57:42 PM(UTC)  | Reason: Not specified

CricutGena Offline
#2 Posted : Saturday, October 12, 2013 3:36:48 PM(UTC)
CricutGena

Rank: Advanced Member

Groups: Registered
Joined: 3/28/2011(UTC)
Posts: 972

Thanks: 4 times
Was thanked: 997 time(s) in 319 post(s)
Hello, please make sure you have installed the blade housing correctly. If it is going through the motions it should cut just fine. If this does not help call customer service at 877-7cricut. We can assist you through the phone.

-Cricut Gena
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.439 seconds.
nebo-cricut-03