Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

AZAuthor Offline
#1 Posted : Monday, October 04, 2010 9:26:15 AM(UTC)
AZAuthor

Rank: Newbie

Groups: Registered
Joined: 9/24/2010(UTC)
Posts: 6
Location: Arizona

I am very new and was using the regular cutting blade which didn't seem to cut through some thicker paper, so I switched to my deep cutter and now I can't seem to get either cutter to work. I think I don't have them installed right since the cutter does not move down to the paper. Please help. Blushing
gcmcevoy Offline
#2 Posted : Monday, October 04, 2010 1:52:32 PM(UTC)
gcmcevoy

Rank: Advanced Member

Groups: Registered
Joined: 7/8/2010(UTC)
Posts: 3,291
United States
Location: New Jersey

Thanks: 532 times
Was thanked: 702 time(s) in 607 post(s)
First make sure you have the housing in correctly . Pop the blade out (be careful it is sharp) blow into where the blade goes there may be paper stuck in it. When you place the blade housing back make sure that the arrow is facing you and tighten up the clamp.
See if that helps.
AZAuthor Offline
#3 Posted : Monday, October 04, 2010 1:58:10 PM(UTC)
AZAuthor

Rank: Newbie

Groups: Registered
Joined: 9/24/2010(UTC)
Posts: 6
Location: Arizona

Thanks. That did help and I also discovered I didn't have it sitting down far enough. It's good now.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.262 seconds.
nebo-cricut-01