Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

chrystalynb1aabe9e Offline
#1 Posted : Sunday, August 03, 2014 6:58:30 AM(UTC)
chrystalynb1aabe9e

Rank: Newbie

Groups: Registered
Joined: 8/3/2014(UTC)
Posts: 4

Thanks: 2 times
Was thanked: 5 time(s) in 3 post(s)
I've got an Asus laptop with Windows 7. I got the Explore yesterday and was SO hoping to play with it last night and/or today! But it said I needed to update firmware/drives whatever. I got as far as loading the Thank You card and now I've got a red power button and I'm going nowhere. And, to boot, my USB connection wasn't being acknowledged by the computer.

Please help! I know I can call customer service tomorrow. But I've got some projects in the works and everyone said that it was so easy to install and have the first project done! Ugh.
 1 user thanked chrystalynb1aabe9e for this useful post.
DarleneDuncan on 8/10/2014(UTC)
Cricut Tamara :) Offline
#2 Posted : Sunday, August 03, 2014 10:33:39 AM(UTC)
Cricut Tamara :)

Rank: Advanced Member

Groups: Circle Moderator, Cricut Community Moderator, Registered
Joined: 10/8/2013(UTC)
Posts: 501

Thanks: 114 times
Was thanked: 241 time(s) in 142 post(s)
Originally Posted by: chrystalynb1aabe9e Go to Quoted Post
I've got an Asus laptop with Windows 7. I got the Explore yesterday and was SO hoping to play with it last night and/or today! But it said I needed to update firmware/drives whatever. I got as far as loading the Thank You card and now I've got a red power button and I'm going nowhere. And, to boot, my USB connection wasn't being acknowledged by the computer.

Please help! I know I can call customer service tomorrow. But I've got some projects in the works and everyone said that it was so easy to install and have the first project done! Ugh.


Hello,

If you click on the arrow by your name, you will get a drop down box with an update firmware option. Click on the update firmware option and follow the prompts. It sounds like the first firmware update that you did might not have completed correctly. This should take care of the red light issue. If this does not work, please give customer support a call tomorrow at 1-877-7cricut and they would be happy to help you out.


Cricut Tamara :)
 2 users thanked Cricut Tamara :) for this useful post.
chrystalynb1aabe9e on 8/10/2014(UTC), DarleneDuncan on 8/14/2014(UTC)
chrystalynb1aabe9e Offline
#3 Posted : Sunday, August 03, 2014 11:16:27 AM(UTC)
chrystalynb1aabe9e

Rank: Newbie

Groups: Registered
Joined: 8/3/2014(UTC)
Posts: 4

Thanks: 2 times
Was thanked: 5 time(s) in 3 post(s)
Originally Posted by: Cricut Tamara :) Go to Quoted Post
Hello,

If you click on the arrow by your name, you will get a drop down box with an update firmware option. Click on the update firmware option and follow the prompts. It sounds like the first firmware update that you did might not have completed correctly. This should take care of the red light issue. If this does not work, please give customer support a call tomorrow at 1-877-7cricut and they would be happy to help you out.


Cricut Tamara :)




Thanks for the reply. I've already tried that as well. It acts as though it has successfully updated... But I get no further than before.
scrapalette Offline
#4 Posted : Sunday, August 03, 2014 9:21:14 PM(UTC)
scrapalette

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Circle Member, Registered
Joined: 7/12/2008(UTC)
Posts: 23,853
United States
Location: FB: Cricut Lovers Guide to Design Space

Thanks: 8587 times
Was thanked: 19161 time(s) in 8569 post(s)
Was your plugin updated? Hoover your mouse over the help in Design Space and if it's red, it needs to be updated. The plugin has to be updated before the firmware is updated.

Close Design Space, turn off the Explore, unplug it from the back, unplug it from your computer and power source. Then plug it all back in and open Design Space and turn on your Explore. That should clear the red light.
 3 users thanked scrapalette for this useful post.
chrystalynb1aabe9e on 8/10/2014(UTC), Cricut Tamara :) on 8/11/2014(UTC), DarleneDuncan on 8/14/2014(UTC)
chrystalynb1aabe9e Offline
#5 Posted : Sunday, August 10, 2014 3:27:46 PM(UTC)
chrystalynb1aabe9e

Rank: Newbie

Groups: Registered
Joined: 8/3/2014(UTC)
Posts: 4

Thanks: 2 times
Was thanked: 5 time(s) in 3 post(s)
I tried all the recommendations and even customer service was temporarily stumped. My update wouldn't install completely on the plug-in and I couldn't ever move forward. So as I was waiting on hold while the CS was attempting to find some other solutions, I proceeded to disable my Windows Firewall. After that, install was a breeze and haven't had a problem since.

Moral of the story: If you get stuck with a red light and the plug-in won't even install, try disabling your computer firewall. I had already attemped disabling my antivirus and it didn't help. Turns out that wasn't the issue. But I wonder how many others have a Windows firewall setup and don't even know it.
 2 users thanked chrystalynb1aabe9e for this useful post.
DarleneDuncan on 8/14/2014(UTC), Kara Williams on 8/20/2014(UTC)
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.417 seconds.
nebo-cricut-03