Flag
  • Sign In
  • 0 items
  • Search
Welcome Guest! Please login to enable all features.

Notification

Icon
Error

cassiesheffield Offline
#1 Posted : Saturday, October 16, 2010 11:49:05 PM(UTC)
cassiesheffield

Rank: Newbie

Groups: Registered
Joined: 10/15/2010(UTC)
Posts: 2

Hi! Newbie here! :) I purchased my machine yesterday and I think something is going on w/ the blade housing. It seems like it's too short or something. Everything I try to cut will not cut. The machine loads correctly, font loads fine on screen, all keys work fine, and when I tell it to cut, it does exactly what it's supposed to and I unload the paper and there's nothing on it! Maybe a scratch here and there and that's it. I don't think the right housing was in my box. That may sound odd, but my machine is white and my blade housing is black and everyone I've contacted says that's not right. I think either someone switched them or Cricut accidentally put the wrong one in the wrong box. My sis n law purchased a Cricut from Wal-Mart a few weeks ago and there was no blade or blade housing in her box at all. She took it back to WM and they just took one out of another box and gave it to her, they said they think people steal them. WOW! Anyway, I've tried dif. cuts, dif. blade depths, dif. pressure, etc; etc; etc; and still nothing. My housing is in the holder right. It is in the holder, screwed in nice and snug and the arrow is facing straight forward. Any suggestions? I hate that there's no help available from Cricut until Monday considering I've spent all this money and I want so badly to be working w/ my machine and it's not complying. :( My hubby wasn't happy about my purchasing the Cricut and now that it's not doing right he's really not happy. Any help is appreciated.Crying


*Bumping this today to hopefully get some help! I did the reboot last night and that didn't help. I have someone coming over now to see if I'm doing something wrong, will let yall know how that goes! Any advice would be kindly appreciated.

Edited by user Sunday, October 17, 2010 2:28:29 PM(UTC)  | Reason: Not specified

cassiesheffield Offline
#2 Posted : Sunday, October 17, 2010 2:30:21 PM(UTC)
cassiesheffield

Rank: Newbie

Groups: Registered
Joined: 10/15/2010(UTC)
Posts: 2

Bumping this to hopefully get some help! I know someone has some advice? Anything?
Maybug Offline
#3 Posted : Sunday, October 17, 2010 8:26:54 PM(UTC)
Maybug

Rank: Newbie

Groups: Registered
Joined: 4/20/2010(UTC)
Posts: 3
Location: MN

I would take it back to where you purchased it and see if you can exchange it.
Narelle Offline
#4 Posted : Sunday, October 17, 2010 9:35:50 PM(UTC)
Narelle

Rank: Advanced Member

Medals: Cricut Circle Member: Member of the Cricut Circle

Groups: Circle Member, Registered
Joined: 9/26/2006(UTC)
Posts: 10,991
Australia
Location: Facebook: Cricut Lovers Guide to Design Space

Thanks: 2036 times
Was thanked: 7901 time(s) in 3704 post(s)
Is the blade in the right way? (Pointy end inside the housing).

Is it blade holder sitting in the correct grooves in the housing?

(Pic courtesy of Scrapalette)


Does the blade poke out the bottom of the blade holder when you press the bit on top of the holder?

Does the housing bounce up and down when you push on it?

Have you tried resetting it? (Is that what you meant by rebooting?)

New reset instructions 25/8/10

1-Turn on your machine with no cartridge loaded.
2-Rolls all the grey dials down to lowest setting.
3-Open up the front where the blade housing sits, use the black arms, with the
screw to pull that entire unit along its track over to the other side of the machine.
4-Over where that unit usually sits, if you reach back there with your fingers, you’ll
feel a red button sticking out.
Push and hold down that button for 5 seconds, counting to 5 slowly. Then let go.
5-Use the black arms to move that unit back into its place where it usually sits.
6-Next you are going to roll all the grey dials all the way up and all the way down 3 times, so three times total for EACH dial-doing 3 cycles of each up & down (may do 1 at a time)
7-Now press the CUT button
8-Turn the machine off
9-Let your machine sit for a FULL 45 min to an hour
10-After that full time passes, load a cartridge on, turn on your machine and try a
practice cut of something simple.

If none of that helps, then I would either give PC a call or as Maybug suggested take it back to the place of purchase.
CarolS Offline
#5 Posted : Saturday, October 30, 2010 11:33:33 PM(UTC)
CarolS

Rank: Advanced Member

Groups: Registered
Joined: 8/21/2009(UTC)
Posts: 341
United States
Location: SE Coastal Georgia

Thanks: 16 times
Was thanked: 102 time(s) in 50 post(s)
Check to make sure you have it setting in there right facing front with a number either from 1 to 6. Sometimes if you don't have it sitting in there right you will not be able to cut with it. I'd also set it at least to a 3.

Alot has to do what you are cutting with it regarding blade depth. What blade depth number do you have it on.

Also check to make sure you put the blade in the housing correctly.

If you feel you do than call Provo Craft and tell them the problem and let them send you a new blade housing unit and blade.
Users browsing this topic
Guest (2)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2014, Yet Another Forum.NET
This page was generated in 0.470 seconds.
nebo-cricut-04